summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJose Antonio Ortega Ruiz <jao@gnu.org>2009-08-23 02:58:13 +0200
committerJose Antonio Ortega Ruiz <jao@gnu.org>2009-08-23 02:58:13 +0200
commitc59998e52dec584d17542059c93692cfbd731bbe (patch)
treeb763e5b5b9c7f8dc40f48072308b8b995e6f51b1 /configure.ac
parent9187b776fdfbb73e0ea6ebe1d203ed2c838fbdbd (diff)
downloadgeiser-c59998e52dec584d17542059c93692cfbd731bbe.tar.gz
geiser-c59998e52dec584d17542059c93692cfbd731bbe.tar.bz2
Autotoolification.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f8ed7ec
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,33 @@
+# Copyright (C) 2009 Free Software Foundation, Inc.
+#
+# This file is free software; as a special exception the author gives
+# unlimited permission to copy and/or distribute it, with or without
+# modifications, as long as this notice is preserved.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+AC_INIT([GNU Geiser],[0.0.7],[jao@gnu.org],geiser)
+AC_CONFIG_SRCDIR([elisp/geiser.el])
+AM_INIT_AUTOMAKE
+
+AC_PROG_MAKE_SET
+AC_PROG_INSTALL
+AC_PROG_MKDIR_P
+AC_CHECK_PROG(MAKEINFO, makeinfo, makeinfo, no)
+AC_CHECK_PROG(TEXI2PDF, texi2pdf, texi2pdf, false)
+
+AM_PATH_LISPDIR
+
+dnl scheme/plt/Makefile
+dnl scheme/plt/geiser/Makefile
+
+AC_CONFIG_FILES([
+Makefile
+elisp/Makefile
+elisp/geiser-version.el
+scheme/Makefile
+])
+
+AC_OUTPUT