summaryrefslogtreecommitdiffhomepage
path: root/configure.in
diff options
context:
space:
mode:
authorjaortega <jaortega>2000-11-01 22:53:21 +0000
committerjaortega <jaortega>2000-11-01 22:53:21 +0000
commit750b5028a18de8a958db63849b5bae84180dad84 (patch)
tree8709a14724122f55048c8a1d6e090d0c80dc92b3 /configure.in
parent50375f34b611281a3b05a37221e2baa143f5f5ca (diff)
downloadmdk-750b5028a18de8a958db63849b5bae84180dad84.tar.gz
mdk-750b5028a18de8a958db63849b5bae84180dad84.tar.bz2
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in56
1 files changed, 56 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..d2386d0
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,56 @@
+# Copyright (C) 2000 Jose Antonio Ortega Ruiz <jaortega@retemail.es>
+#
+# This file is free software; as a special exception the author gives
+# unlimited permission to copy and/or distribute it, with or without
+# modifications, as long as this notice is preserved.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+AC_INIT(mixlib/mix.h)
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE(mdk,0.1)
+
+AM_MAINTAINER_MODE
+
+AC_ISC_POSIX
+AC_PROG_CC
+AM_PROG_CC_STDC
+AC_HEADER_STDC
+
+AM_PROG_LEX
+AC_PROG_RANLIB
+
+dnl i18n stuff
+ALL_LINGUAS="ca"
+AM_GNU_GETTEXT
+
+test "x$prefix" = xNONE && prefix=$ac_default_prefix
+
+AC_DEFINE_UNQUOTED(LOCALEDIR, "${prefix}/share/locale")
+
+dnl Check for readline and history
+AC_CHECK_LIB(readline, readline, , AC_MSG_ERROR(Cannot find GNU readline lib))
+AC_CHECK_LIB(history, add_history, , AC_MSG_ERROR(Cannot GNU history lib))
+
+
+dnl Check for glib
+AM_PATH_GLIB(1.2.0,
+ [LIBS="$LIBS $GLIB_LIBS" CFLAGS="$CFLAGS $GLIB_CFLAGS"],
+ AC_MSG_ERROR(Cannot find GLIB), "gmodule" )
+
+CFLAGS="$CFLAGS -Wall"
+AC_SUBST(CFLAGS)
+
+AC_OUTPUT(
+Makefile
+doc/Makefile
+doc/html/Makefile
+mixlib/Makefile
+mixlib/testsuite/Makefile
+mixutils/Makefile
+intl/Makefile
+samples/Makefile
+po/Makefile.in
+)