summaryrefslogtreecommitdiffhomepage
path: root/configure.in
diff options
context:
space:
mode:
authorJose Antonio Ortega Ruiz <jao@gnu.org>2001-04-07 22:12:31 +0000
committerJose Antonio Ortega Ruiz <jao@gnu.org>2001-04-07 22:12:31 +0000
commit10418b21cfb99f506743af0ca3d5f338c13079cd (patch)
treed4f3dbf2b6a4e5c2a41f15978d146d8d36b63f79 /configure.in
parenta161fa578bd50daf971186d0be08d89619aa58d1 (diff)
downloadmdk-10418b21cfb99f506743af0ca3d5f338c13079cd.tar.gz
mdk-10418b21cfb99f506743af0ca3d5f338c13079cd.tar.bz2
getopt and getopt_long provided if missing
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 106c02f..990af09 100644
--- a/configure.in
+++ b/configure.in
@@ -69,12 +69,12 @@ AC_ARG_ENABLE(gui,
esac],[gui=true])
dnl Check for gtk+
-if test x$gui = xtrue; then
- AM_PATH_GTK(1.2.0,
- [LIBS="$LIBS $GTK_LIBS" CFLAGS="$CFLAGS $GTK_CFLAGS"],
- [AC_MSG_WARN(Cannot find GTK+: the GUI shall not be built) gui=false],
- "gmodule" )
-fi
+dnl if test x$gui = xtrue; then
+dnl AM_PATH_GTK(1.2.0,
+dnl [LIBS="$LIBS $GTK_LIBS" CFLAGS="$CFLAGS $GTK_CFLAGS"],
+dnl [AC_MSG_WARN(Cannot find GTK+: the GUI shall not be built) gui=false],
+dnl "gmodule" )
+dnl fi
dnl Check for libglade
if test x$gui = xtrue; then
@@ -83,6 +83,9 @@ if test x$gui = xtrue; then
[AC_MSG_WARN(Cannot find GTK+: the GUI shall not be built) gui=false])
fi
+dnl use the provided getopt if gnu getopt is not available
+AC_REPLACE_FUNCS(getopt_long)
+
AM_CONDITIONAL(MAKE_GUI, test x$gui = xtrue)
CFLAGS="$CFLAGS -Wall"
@@ -96,6 +99,7 @@ mixlib/Makefile
mixlib/testsuite/Makefile
mixutils/Makefile
mixgtk/Makefile
+lib/Makefile
misc/Makefile
intl/Makefile
samples/Makefile