summaryrefslogtreecommitdiffhomepage
path: root/configure.in
diff options
context:
space:
mode:
authorJose Antonio Ortega Ruiz <jao@gnu.org>2002-04-08 00:26:37 +0000
committerJose Antonio Ortega Ruiz <jao@gnu.org>2002-04-08 00:26:37 +0000
commit2c40b5475f0b968dcd5ac2f6d9e353c9f5463763 (patch)
tree35eaa686e43847fb0b603a2169251a913e2e18d5 /configure.in
parent254ae3871839a7e931bac84df475e571fee3d2d9 (diff)
downloadmdk-2c40b5475f0b968dcd5ac2f6d9e353c9f5463763.tar.gz
mdk-2c40b5475f0b968dcd5ac2f6d9e353c9f5463763.tar.bz2
candidate release 1.0
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 19 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index 768dcb7..d6c5cea 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
# Copyright (C) 2000, 2001, 2002 Free Software Foundation, Inc.
#
-# $Id: configure.in,v 1.17 2002/03/20 01:33:14 jao Exp $
+# $Id: configure.in,v 1.18 2002/04/08 00:29:59 jao Exp $
#
# This file is free software; as a special exception the author gives
# unlimited permission to copy and/or distribute it, with or without
@@ -12,7 +12,7 @@
AC_INIT(mixlib/mix.h)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(mdk,0.5)
+AM_INIT_AUTOMAKE(mdk,1.0)
AM_MAINTAINER_MODE
@@ -43,20 +43,17 @@ esac], [readl=true])
if test x$readl = xtrue; then
AC_CHECK_LIB(ncurses, initscr, ,
- [AC_MSG_WARN(Cannot find ncurses lib)
- readl=false])
+ [AC_MSG_WARN(Cannot find ncurses lib) readl=false])
fi
if test x$readl = xtrue; then
AC_CHECK_LIB(readline, readline, ,
- [AC_MSG_WARN(Cannot find GNU readline lib)
- readl=false])
+ [AC_MSG_WARN(Cannot find GNU readline lib) readl=false])
fi
if test x$readl = xtrue; then
AC_CHECK_LIB(history, add_history, ,
- [AC_MSG_WARN(Cannot find GNU history lib)
- readl=false])
+ [AC_MSG_WARN(Cannot find GNU history lib) readl=false])
dnl old versions of readline use completion_matches instead
dnl of rl_completion_matches
AC_CHECK_FUNCS(rl_completion_matches,,)
@@ -92,9 +89,7 @@ AM_CONDITIONAL(MAKE_GUILE, test x$wguile = xtrue)
dnl Check for glib
AM_PATH_GLIB(1.2.0,
- [LIBS="$LIBS $GLIB_LIBS"
- CFLAGS="$CFLAGS
- $GLIB_CFLAGS"],
+ [LIBS="$LIBS $GLIB_LIBS" CFLAGS="$CFLAGS $GLIB_CFLAGS"],
AC_MSG_ERROR(Cannot find GLIB), "gmodule" )
dnl Check if the gtk gui is required
@@ -127,23 +122,28 @@ AC_REPLACE_FUNCS(getopt_long)
AM_CONDITIONAL(MAKE_GUI, test x$gui = xtrue)
-CFLAGS="$CFLAGS -Wall"
+AC_CANONICAL_HOST
+case "${host_os}" in
+darwin*) CFLAGS="$CFLAGS -Wall -traditional-cpp";;
+*) CFLAGS="$CFLAGS -Wall";;
+esac
+
AC_SUBST(CFLAGS)
-AC_OUTPUT(
-Makefile
-doc/Makefile
-doc/img/Makefile
-mixlib/Makefile
+AC_OUTPUT(
+Makefile
+doc/Makefile
+doc/img/Makefile
+mixlib/Makefile
mixlib/testsuite/Makefile
mixguile/Makefile
mixutils/Makefile
mixgtk/Makefile
lib/Makefile
misc/Makefile
-intl/Makefile
+intl/Makefile
samples/Makefile
-po/Makefile.in
+po/Makefile.in
)
if test x$readl = xtrue; then