summaryrefslogtreecommitdiffhomepage
path: root/configure.in
diff options
context:
space:
mode:
authorJose Antonio Ortega Ruiz <jao@gnu.org>2008-03-17 01:12:35 +0100
committerJose Antonio Ortega Ruiz <jao@gnu.org>2008-03-17 01:12:35 +0100
commit974444c6417490ce9cb6bb35ecf1c64d9b446044 (patch)
tree484c6a248d052e201e622a5018709fcef2946040 /configure.in
parent5f74041ed9f69a065b675f738e3ecbb0cea067ae (diff)
downloadmdk-974444c6417490ce9cb6bb35ecf1c64d9b446044.tar.gz
mdk-974444c6417490ce9cb6bb35ecf1c64d9b446044.tar.bz2
Properly set external commands, taking into account the host type
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 76b9757..de6e3e1 100644
--- a/configure.in
+++ b/configure.in
@@ -133,10 +133,17 @@ if test x$gui = xtrue; then
AM_CFLAGS="$AM_CFLAGS -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED"
fi
-dnl use the provided getopt if gnu getopt is not available
-AC_REPLACE_FUNCS(getopt_long)
+dnl Are we in a darwin system?
+case "${host_os}" in
+ darwin*) darwin_system=true;;
+ *) darwin_system=false;
+esac
AM_CONDITIONAL(MAKE_GUI, test x$gui = xtrue)
+AM_CONDITIONAL(DARWIN_SYSTEM, test x$darwin_system = xtrue)
+
+dnl use the provided getopt if gnu getopt is not available
+AC_REPLACE_FUNCS(getopt_long)
AC_SUBST(AM_CFLAGS)