summaryrefslogtreecommitdiffhomepage
path: root/configure.in
diff options
context:
space:
mode:
authorjaortega <jaortega>2001-03-22 02:33:58 +0000
committerjaortega <jaortega>2001-03-22 02:33:58 +0000
commit2ca96c58673afb1df494ae5b5b00256c140ce3d6 (patch)
tree7e70b3fe75884c837b7e674a13d3e08e1268f233 /configure.in
parent92e00ea7d9a1aa5b202495e993c5e69915c4ffee (diff)
downloadmdk-2ca96c58673afb1df494ae5b5b00256c140ce3d6.tar.gz
mdk-2ca96c58673afb1df494ae5b5b00256c140ce3d6.tar.bz2
minor changes
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 27 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a8c1c47..c27cde4 100644
--- a/configure.in
+++ b/configure.in
@@ -31,9 +31,28 @@ test "x$prefix" = xNONE && prefix=$ac_default_prefix
AC_DEFINE_UNQUOTED(LOCALEDIR, "${prefix}/share/locale")
dnl Check for readline and history
-AC_CHECK_LIB(ncurses, initscr, , AC_MSG_ERROR(Cannot find ncurses lib))
-AC_CHECK_LIB(readline, readline, , AC_MSG_ERROR(Cannot find GNU readline lib))
-AC_CHECK_LIB(history, add_history, , AC_MSG_ERROR(Cannot find GNU history lib))
+AC_ARG_WITH(readline,
+[ --with-readline build mixvm with readline support],
+[case "${withval}" in
+ yes) readl=true ;;
+ no) readl=false ;;
+ *) AC_MSG_ERROR(bad value ${withval} for --with-readline) ;;
+esac], [readl=true])
+
+if test x$readl = xtrue; then
+ AC_CHECK_LIB(ncurses, initscr, ,
+ [AC_MSG_WARN(Cannot find ncurses lib) readl=false])
+fi
+
+if test x$readl = xtrue; then
+ AC_CHECK_LIB(readline, readline, ,
+ [AC_MSG_WARN(Cannot find GNU readline lib) readl=false])
+fi
+
+if test x$readl = xtrue; then
+AC_CHECK_LIB(history, add_history, ,
+ [AC_MSG_WARN(Cannot find GNU history lib) readl=false])
+fi
dnl Check for glib
AM_PATH_GLIB(1.2.0,
@@ -83,11 +102,15 @@ samples/Makefile
po/Makefile.in
)
+if test x$readl = xtrue; then
+ addinfo=", with readline support"
+fi
+
echo
echo "*** GNU MDK $VERSION has been successfully configured. ***"
echo
echo "Type make to build the following utilities:"
-echo " - mixasm (MIX assembler)"
+echo " - mixasm (MIX assembler${addinfo})"
echo " - mixvm (MIX virtual machine)"
if test x$gui = xtrue; then
echo " - gmixvm (mixvm GTK+ GUI)"