summaryrefslogtreecommitdiffhomepage
path: root/mixguile/Makefile.am
diff options
context:
space:
mode:
authorJose Antonio Ortega Ruiz <jao@gnu.org>2001-08-21 00:30:40 +0000
committerJose Antonio Ortega Ruiz <jao@gnu.org>2001-08-21 00:30:40 +0000
commit05497ded5eb3d81febeba4852ebef3e6d9283a74 (patch)
treeef9bffff4f905744d0fa81f1db98e24a2aa0e48c /mixguile/Makefile.am
parentb32560c287b0484ac111bc88678db75ad4487d56 (diff)
downloadmdk-05497ded5eb3d81febeba4852ebef3e6d9283a74.tar.gz
mdk-05497ded5eb3d81febeba4852ebef3e6d9283a74.tar.bz2
initial guile support
Diffstat (limited to 'mixguile/Makefile.am')
-rw-r--r--mixguile/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/mixguile/Makefile.am b/mixguile/Makefile.am
new file mode 100644
index 0000000..15d6308
--- /dev/null
+++ b/mixguile/Makefile.am
@@ -0,0 +1,24 @@
+## Process this file with automake to produce Makefile.in
+
+# Copyright (C) 2001 Free Software Foundation, Inc.
+#
+# This file is free software; as a special exception the author gives
+# unlimited permission to copy and/or distribute it, with or without
+# modifications, as long as this notice is preserved.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+INCLUDES = -I$(includedir) -DG_LOG_DOMAIN=\"libmixguile\"
+
+noinst_LIBRARIES = libmixguile.a
+
+if MAKE_GUILE
+libmixguile_a_SOURCES = mixguile.h mixguile.c \
+ mixguile_cmd_dispatcher.h mixguile_cmd_dispatcher.c
+
+else
+libmixguile_a_SOURCES =
+
+endif