summaryrefslogtreecommitdiffhomepage
path: root/mixlib/testsuite/Makefile.am
diff options
context:
space:
mode:
authorjaortega <jaortega>2000-11-01 22:53:21 +0000
committerjaortega <jaortega>2000-11-01 22:53:21 +0000
commit750b5028a18de8a958db63849b5bae84180dad84 (patch)
tree8709a14724122f55048c8a1d6e090d0c80dc92b3 /mixlib/testsuite/Makefile.am
parent50375f34b611281a3b05a37221e2baa143f5f5ca (diff)
downloadmdk-750b5028a18de8a958db63849b5bae84180dad84.tar.gz
mdk-750b5028a18de8a958db63849b5bae84180dad84.tar.bz2
Diffstat (limited to 'mixlib/testsuite/Makefile.am')
-rw-r--r--mixlib/testsuite/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/mixlib/testsuite/Makefile.am b/mixlib/testsuite/Makefile.am
new file mode 100644
index 0000000..62d5db6
--- /dev/null
+++ b/mixlib/testsuite/Makefile.am
@@ -0,0 +1,26 @@
+# Copyright (C) 1999 jose antonio ortega ruiz <jaortega@acm.org>
+#
+# This file is free software; as a special exception the author gives
+# unlimited permission to copy and/or distribute it, with or without
+# modifications, as long as this notice is preserved.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+INCLUDES = -I..
+LDADD = $(top_builddir)/mixlib/libmix.a
+
+check_PROGRAMS = mixtypest mixinstest mixvminstest mixparsertest mixdevtest
+TESTS = $(check_PROGRAMS)
+
+mixtypest_SOURCES = test.h mix_types_t.c
+mixinstest_SOURCES = test.h mix_ins_t.c
+mixvminstest_SOURCES = test.h mix_vm_ins_t.c
+mixparsertest_SOURCES = test.h mix_parser_t.c
+mixdevtest_SOURCES = test.h mix_device_t.c
+
+
+
+
+