summaryrefslogtreecommitdiffhomepage
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 106c02f..990af09 100644
--- a/configure.in
+++ b/configure.in
@@ -69,12 +69,12 @@ AC_ARG_ENABLE(gui,
esac],[gui=true])
dnl Check for gtk+
-if test x$gui = xtrue; then
- AM_PATH_GTK(1.2.0,
- [LIBS="$LIBS $GTK_LIBS" CFLAGS="$CFLAGS $GTK_CFLAGS"],
- [AC_MSG_WARN(Cannot find GTK+: the GUI shall not be built) gui=false],
- "gmodule" )
-fi
+dnl if test x$gui = xtrue; then
+dnl AM_PATH_GTK(1.2.0,
+dnl [LIBS="$LIBS $GTK_LIBS" CFLAGS="$CFLAGS $GTK_CFLAGS"],
+dnl [AC_MSG_WARN(Cannot find GTK+: the GUI shall not be built) gui=false],
+dnl "gmodule" )
+dnl fi
dnl Check for libglade
if test x$gui = xtrue; then
@@ -83,6 +83,9 @@ if test x$gui = xtrue; then
[AC_MSG_WARN(Cannot find GTK+: the GUI shall not be built) gui=false])
fi
+dnl use the provided getopt if gnu getopt is not available
+AC_REPLACE_FUNCS(getopt_long)
+
AM_CONDITIONAL(MAKE_GUI, test x$gui = xtrue)
CFLAGS="$CFLAGS -Wall"
@@ -96,6 +99,7 @@ mixlib/Makefile
mixlib/testsuite/Makefile
mixutils/Makefile
mixgtk/Makefile
+lib/Makefile
misc/Makefile
intl/Makefile
samples/Makefile