summaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
authorAlex Ameen <alex.ameen.tx@gmail.com>2019-03-01 01:17:16 -0600
committerjao <jao@gnu.org>2019-03-15 21:44:13 +0000
commiteecb66f3f8dbb7c3dab4b4d86fe69620d126b0f2 (patch)
tree40f3d0fd841aa91f4c947340254523a97ec15bf7 /default.nix
parent8b0eef393a624e664923bf7d64efe9f15af5edd6 (diff)
downloadxmobar-eecb66f3f8dbb7c3dab4b4d86fe69620d126b0f2.tar.gz
xmobar-eecb66f3f8dbb7c3dab4b4d86fe69620d126b0f2.tar.bz2
adding ignores
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..95d959e
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,42 @@
+{ mkDerivation, alsa-core, alsa-mixer, async, base, bytestring
+, containers, dbus, directory, extensible-exceptions, filepath
+, hinotify, hspec, http-conduit, http-types, iwlib, libmpd, libXpm
+, libXrandr, libXrender, mtl, old-locale, parsec, parsec-numbers
+, process, regex-compat, stdenv, stm, temporary, time
+, timezone-olson, timezone-series, transformers, unix, utf8-string
+, wirelesstools, X11, X11-xft
+}:
+mkDerivation {
+ pname = "xmobar";
+ version = "0.29.5";
+ src = ./.;
+ configureFlags = [
+ "-fwith_alsa" "-fwith_conduit" "-fwith_datezone" "-fwith_dbus"
+ "-fwith_inotify" "-fwith_iwlib" "-fwith_mpd" "-fwith_mpris"
+ "-fwith_rtsopts" "-fwith_threaded" "-fwith_utf8" "-fwith_uvmeter"
+ "-fwith_weather" "-fwith_xft" "-fwith_xpm"
+ ];
+ isLibrary = true;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ alsa-core alsa-mixer async base bytestring containers dbus
+ directory extensible-exceptions filepath hinotify http-conduit
+ http-types iwlib libmpd mtl old-locale parsec parsec-numbers
+ process regex-compat stm time timezone-olson timezone-series
+ transformers unix utf8-string X11 X11-xft
+ ];
+ librarySystemDepends = [
+ libXpm libXrandr libXrender wirelesstools
+ ];
+ executableHaskellDepends = [
+ async base containers directory filepath parsec unix X11
+ ];
+ testHaskellDepends = [
+ alsa-core alsa-mixer async base bytestring containers directory
+ filepath hspec mtl old-locale parsec parsec-numbers process
+ regex-compat stm temporary time transformers unix X11
+ ];
+ homepage = "http://xmobar.org";
+ description = "A Minimalistic Text Based Status Bar";
+ license = stdenv.lib.licenses.bsd3;
+}