summaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/default.nix b/default.nix
deleted file mode 100644
index dc49456..0000000
--- a/default.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-{ mkDerivation, alsa-core, alsa-mixer, async, base, bytestring
-, containers, dbus, directory, extensible-exceptions, filepath
-, hinotify, hspec, http-conduit, http-types, iwlib, libmpd, libXpm
-, libXrandr, libXrender, mtl, old-locale, parsec, parsec-numbers
-, process, regex-compat, stdenv, stm, temporary, time
-, timezone-olson, timezone-series, transformers, unix, utf8-string
-, wirelesstools, X11, X11-xft
-}:
-mkDerivation {
- pname = "xmobar";
- version = "0.29.5";
- src = ./.;
- configureFlags = [
- "-fwith_alsa" "-fwith_conduit" "-fwith_datezone" "-fwith_dbus"
- "-fwith_inotify" "-fwith_iwlib" "-fwith_mpd" "-fwith_mpris"
- "-fwith_rtsopts" "-fwith_threaded" "-fwith_utf8" "-fwith_uvmeter"
- "-fwith_weather" "-fwith_xft" "-fwith_xpm"
- ];
- isLibrary = true;
- isExecutable = true;
- libraryHaskellDepends = [
- alsa-core alsa-mixer async base bytestring containers dbus
- directory extensible-exceptions filepath hinotify http-conduit
- http-types iwlib libmpd mtl old-locale parsec parsec-numbers
- process regex-compat stm time timezone-olson timezone-series
- transformers unix utf8-string X11 X11-xft
- ];
- librarySystemDepends = [
- libXpm libXrandr libXrender wirelesstools
- ];
- executableHaskellDepends = [
- async base containers directory filepath parsec unix X11
- ];
- testHaskellDepends = [
- alsa-core alsa-mixer async base bytestring containers directory
- filepath hspec mtl old-locale parsec parsec-numbers process
- regex-compat stm temporary time transformers unix X11
- ];
- doCheck = false;
- homepage = "https://github.com/jaor/xmobar";
- description = "A Minimalistic Text Based Status Bar";
- license = stdenv.lib.licenses.bsd3;
-}