summaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorJose Antonio Ortega Ruiz <jao@gnu.org>2014-01-06 05:32:05 +0100
committerJose Antonio Ortega Ruiz <jao@gnu.org>2014-01-06 05:32:05 +0100
commitfd6af75970ec60598c0bc3e1adcfcd2cb8b1da52 (patch)
tree7e98cd9dd93f3d8965a43b2c002cd56aceadf9fe /configure.ac
parent6baade238e8f444cd0fad56c5eee37c510def90d (diff)
downloadmdk-fd6af75970ec60598c0bc3e1adcfcd2cb8b1da52.tar.gz
mdk-fd6af75970ec60598c0bc3e1adcfcd2cb8b1da52.tar.bz2
Fixes for building with --without-guile
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5b8d40c..a78ef23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
# Copyright (C) 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2008, 2009,
-# 2010, 2013 Free Software Foundation, Inc.
+# 2010, 2013, 2014 Free Software Foundation, Inc.
#
# This file is free software; as a special exception the author gives
# unlimited permission to copy and/or distribute it, with or without
@@ -9,7 +9,7 @@
# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-AC_INIT([GNU MDK],1.2.7,[bug-mdk@gnu.org],mdk)
+AC_INIT([GNU MDK],1.2.8,[bug-mdk@gnu.org],mdk)
AC_CONFIG_SRCDIR([mixlib/mix.h])
AM_INIT_AUTOMAKE
@@ -80,6 +80,9 @@ dnl of rl_completion_matches
AC_CHECK_FUNCS(rl_completion_matches,,)
fi
+dnl Check for glib
+PKG_CHECK_MODULES(GLIB,glib-2.0 >= 2.0)
+
dnl Check for guile
AC_ARG_WITH(guile,
[ --without-guile build MDK without Guile support],
@@ -101,9 +104,6 @@ fi
AM_CONDITIONAL(MAKE_GUILE, test x$wguile = xtrue)
-dnl Check for glib
-PKG_CHECK_MODULES(GLIB,glib-2.0 >= 2.0)
-
LIBS="$LIBS $GLIB_LIBS"
AM_CFLAGS="$AM_CFLAGS $GLIB_CFLAGS -DG_DISABLE_DEPRECATED"